Unlock iPhone, Jailbreak iPhone and iPhone Unlocking

Jailbroken iPhones Not Compatible to iPhone 3.1.3 OS Update

2/05/2010 10:06:00 PM - 8 comments
Seems it’s the season for iPhone updates! It has been quite a while since the iPhone OS has been updated and following closely the release of the iPad and announcements of VoIP for 3G and Skype update comes the news of the iPhone OS newest version, the iPhone OS 3.1.3.

The iPhone 3.1.3 OS is available for all iPhone versions and is also compatible with all iPod Touch versions. Although there isn’t much concrete content to go with this new update, Apple assures that it will definitely look into fixing the occasional bugs and errors that accompanies every single update – and might come along with iPhone 3.1.3 OS too.

Apple also stated that the updated iPhone 3.1.3 OS will offer enhanced accuracy for battery level reports on the iPhone 3GS and repair problems that some Third Party Apps have had launching. It also fixes a problem that has been going on with the iPhone not working properly with the Japanese Kana keyboard.

Geohot confirms: Blackra1n & Blacksn0w not ready for the latest update

George Hotz (popularly Geohot) has confirmed that Blackra1n and Blacksn0w tools are not yet compatible with the latest iPhone 3.1.3 firmware. In a recent tweet, Geohot shares that the new firmware brings 05.12.01 baseband for iPhone 3GS and iPhone 3G which restricts jailbreaking and unlocking on newer devices.

iPhone 3.1.3 OS Update & Dev Team’s Note for Jailbroken iPhone

The iphone dev team has as quickly as always updated its followers about Apple iPhone 3.1.3 OS and its effect on jailbroken iPhone. In their latest blog post ‘3.1.3 and thee’ in the iphone dev team blog it posted a warning iPhone users with jailbroken devices to not update their device - 3G and 3G(S). It has been further explained that PwnageTool and redsn0w are not yet compatible with 3.1.3 and there is not instant solution to this.

The dev team has also urged its followers to not ‘bug’ then regarding this since no estimated time frame is possible at this moment regarding the release of compatible tools to work for iPhone 3.1.3 OS. However, all of you who have jailbreak iPhone keep a check on this space as we promise to keep you updated.


Posted: Seuli.B

8 Responses

Wish I'd have read this before I stupidly updated my jailbroken iphone! Thanks for the info though and will certainly be keeping a watchful eye on the availability of a patch.

same problem... iphone 3g 3.1.3 baseband 05.12.01 ... need to unlock! HELPPPPP!!!

at least I'm not alone, just waiting...

(did manage to downgrade back to 3.1.2 blackra1n 0.92)

yo tengo la version 3.1.2 baseband 05.11.07 y tampoco puedo ayudaaaaaaa por favor !!!!

need to unlock 3.1.3 (modem firmware 05.12.01)

... iphone 3g 3.1.3 baseband 05.12.01 ... need to unlock

we are not alone!

Well what can I say? Not much really, just read that Geohot thinks we're all stupid, and I admit it I am! Why didn't I realise, well, even worse news is he says it it easy to jailbreak, but that it appears he won't be bringing out the software to do it? Come on Geohot help the unfortunate fools, please?!!!!!!

Post a Comment